[Geany-Users] [ANN] Geany-Plugins 1.27 is out!

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Geany-Users] [ANN] Geany-Plugins 1.27 is out!

Frank Lanitz
Hi users, friends, everybody,

We are happy to announce a new version of the combined Geany-Plugins
release -- right after Geany 1.27, Geany-Plugins 1.27 has been released.

There have been a lot of changes, but here are some of the most
prominent or noteworthy ones.

General:
* Dropped build support via Waf -- please use Autotools instead
* Improve building on Windows a lot and so ship more plugins with
  installer for Windows
* New plugin LineOperations
* i18n/l10n: Update of translations for de, fr, pt, ru

Plugins itself:
* Debugger: Fix many memory leaks and potential crashes
* Debugger: Fix handling of non-ASCII characters in file names
* Debugger: Speed up stack trace display on large traces
* Debugger: Report the signal name when the process received one
* GeanyPy: Add keybinding support for Python plugins
* GeniusPaste: Make pastebins configurable via configuration files,
  adding support for user-defined pastebins
* GeniusPaste: Add configurations for fpaste.org and paste.debian.net
* ProjectOrganizer: Use the term "symbol" instead of "tag"
* Spellcheck: Improve detection of English contractions and other use
  of single quotes

A more complete list of changes can be found in the NEWS file at
https://raw.githubusercontent.com/geany/geany-plugins/1.27.0/NEWS

As usual, you can find source tarballs and Windows installer for the new
release on plugins.geany.org.

A huge thanks to everybody contributing to this great release.

Have nice time!

Cheers,
Frank


_______________________________________________
Users mailing list
[hidden email]
https://lists.geany.org/cgi-bin/mailman/listinfo/users

signature.asc (836 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Geany-Users] [ANN] Geany-Plugins 1.27 is out!

Thomas Martitz-2
Am 13.03.2016 um 16:26 schrieb Frank Lanitz:
> Hi users, friends, everybody,
>
> We are happy to announce a new version of the combined Geany-Plugins
> release -- right after Geany 1.27, Geany-Plugins 1.27 has been released.
>

Good work everybody!


> * GeanyPy: Add keybinding support for Python plugins
>

geanypy also became a proxy plugin. Some think this is not interesting
for the end-user. However there is an important note that goes with it:
the location for geanypy plugins has changed. They must be placed into
the same directory as other plugins. Also, geanypy used to ship a
separate plugin manager. This is not the case anymore. geanypy plugins
are now displayed in the standard plugin manager, just below  geanypy
itself.

So, move all your existing plugins to ~/.config/geany/plugins. Code
changes shouldn't be necessary.

For keybindings support, there are new APIs which are loosely modelled
after Geany's C API:
In your __init__(self) do something like (this is just a quick example,
checkout geanypy for details):

self.kb_group = self.add_key_group("foo_bar", 2)
self.kb_group.add_key_item("action1", "Action 1", self.on_action_1)
[...]


Best regards
_______________________________________________
Users mailing list
[hidden email]
https://lists.geany.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Geany-Users] [ANN] Geany-Plugins 1.27 is out!

Lex Trotman
Thomas,

Can you make a pull request on the README of Geanypy in G-P that
explains these new things for Python plugin makers.  I'm not sure I
understand details enough to get it right.

Also you can remove the warning that there would be incompatabilities
in 1.27 since you did a good job maintaining backward compatability :)

Cheers
Lex



On 14 March 2016 at 19:15, Thomas Martitz <[hidden email]> wrote:

> Am 13.03.2016 um 16:26 schrieb Frank Lanitz:
>>
>> Hi users, friends, everybody,
>>
>> We are happy to announce a new version of the combined Geany-Plugins
>> release -- right after Geany 1.27, Geany-Plugins 1.27 has been released.
>>
>
> Good work everybody!
>
>
>> * GeanyPy: Add keybinding support for Python plugins
>>
>
> geanypy also became a proxy plugin. Some think this is not interesting for
> the end-user. However there is an important note that goes with it: the
> location for geanypy plugins has changed. They must be placed into the same
> directory as other plugins. Also, geanypy used to ship a separate plugin
> manager. This is not the case anymore. geanypy plugins are now displayed in
> the standard plugin manager, just below  geanypy itself.
>
> So, move all your existing plugins to ~/.config/geany/plugins. Code changes
> shouldn't be necessary.
>
> For keybindings support, there are new APIs which are loosely modelled after
> Geany's C API:
> In your __init__(self) do something like (this is just a quick example,
> checkout geanypy for details):
>
> self.kb_group = self.add_key_group("foo_bar", 2)
> self.kb_group.add_key_item("action1", "Action 1", self.on_action_1)
> [...]
>
>
> Best regards
> _______________________________________________
> Users mailing list
> [hidden email]
> https://lists.geany.org/cgi-bin/mailman/listinfo/users
_______________________________________________
Users mailing list
[hidden email]
https://lists.geany.org/cgi-bin/mailman/listinfo/users
Loading...