[Geany-Users] installing LispEdit plugin

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Geany-Users] installing LispEdit plugin

Amir Teymuri
I am following the instructions in the HOWTO.pdf in
https://github.com/tgutu/geanylispedit.

I am using ubuntu 16 and have geany installed via software center. In
/usr/lib/ there is no directory named geany, where i should put the so
file in, as instructed in the pdf file.
I have created a geany folder and put the so file in it, but still
nothing connected to lisp in the Tools>plugin manager to find. If anyone
has experience using common lisp / lisp on geany i would be thankful if
you could tell me your solutions.

Regards,
Amir
_______________________________________________
Users mailing list
[hidden email]
https://lists.geany.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Geany-Users] installing LispEdit plugin

Lex Trotman
menu->help->debug messges one shows system plugin path

Cheers
Lex

On 11 May 2016 at 22:08, amir teymuri <[hidden email]> wrote:

> I am following the instructions in the HOWTO.pdf in
> https://github.com/tgutu/geanylispedit.
>
> I am using ubuntu 16 and have geany installed via software center. In
> /usr/lib/ there is no directory named geany, where i should put the so file
> in, as instructed in the pdf file.
> I have created a geany folder and put the so file in it, but still nothing
> connected to lisp in the Tools>plugin manager to find. If anyone has
> experience using common lisp / lisp on geany i would be thankful if you
> could tell me your solutions.
>
> Regards,
> Amir
> _______________________________________________
> Users mailing list
> [hidden email]
> https://lists.geany.org/cgi-bin/mailman/listinfo/users
_______________________________________________
Users mailing list
[hidden email]
https://lists.geany.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Geany-Users] installing LispEdit plugin

Colomban Wendling
In reply to this post by Amir Teymuri
Hi,

Le 11/05/2016 à 14:08, amir teymuri a écrit :
> I am following the instructions in the HOWTO.pdf in
> https://github.com/tgutu/geanylispedit.
>
> I am using ubuntu 16 and have geany installed via software center. In
> /usr/lib/ there is no directory named geany, where i should put the so
> file in, as instructed in the pdf file.

The "Installing the plugin" section in that guide probably won't work
for you: it relies on downloading a pre-built binary plugin from 5 years
ago.  It's even a 32-bits plugin, and you're likely to require a 64-bits
one.

You can however build that plugin yourself.  It's not very hard,
although the build system requires a little tweaking.  As teh build
system on that plugin doesn't work out of the box anymore, the easiest
solution if you're not familiar with building C programs is:

* install the required packages: gcc, libgtk2.0-dev and libvte-dev
* open a terminal, and change directory to the plugin's top directory
* run the following command:

> gcc -Werror=implicit-function-declaration -shared -fPIC -o geanylispedit.so src/geanylispedit.c $(pkg-config --libs --cflags geany vte)

Then, copy the generated geanylispedit.so file into your user's Geany
configuration directory:

> mkdir -p ~/.config/geany/plugins/
> install geanylispedit.so ~/.config/geany/plugins/

Restart Geany, and you should see the plugin in the Plugin Manager.
If not, as Lex asked, show us the Debug Messages so we can dig further.

Here is a fully functional set of commands to download, build and
install the plugin, in case you're not familiar enough with the command
line.  You however still need to install the dependencies yourself
beforehand.

> wget https://github.com/tgutu/geanylispedit/archive/master.zip -O geanylispedit-master.zip
> unzip geanylispedit-master.zip
> cd geanylispedit-master/
> gcc -Werror=implicit-function-declaration -shared -fPIC -o geanylispedit.so src/geanylispedit.c $(pkg-config --libs --cflags geany vte)
> mkdir -p ~/.config/geany/plugins/
> install geanylispedit.so ~/.config/geany/plugins/

Regards,
Colomban


> I have created a geany folder and put the so file in it, but still
> nothing connected to lisp in the Tools>plugin manager to find.

That's expected.  The Ubuntu build of Geany will search for plugins in
/usr/lib/x86_64-linux-gnu/geany/ (or /usr/lib/i386-linux-gnu/geany/ on
32 bits systems), not in /usr/lib/geany/.  Anyway, downloading a 5 years
old pre-built binary off the internet to use on a very recent OS is not
a very nice solution, as it's likely not to work so well.
_______________________________________________
Users mailing list
[hidden email]
https://lists.geany.org/cgi-bin/mailman/listinfo/users
Loading...